[paludis-user] Trying to move to paludis

Alon Bar-Lev alon.barlev at gmail.com
Wed May 21 21:12:23 UTC 2008


On 5/22/08, Ciaran McCreesh <ciaran.mccreesh at googlemail.com> wrote:
> On Thu, 22 May 2008 00:04:29 +0300
>
> "Alon Bar-Lev" <alon.barlev at gmail.com> wrote:
>
> > >  > But ipw2200-firmware has:
>  > >  > RDEPEND="|| ( >=sys-fs/udev-096 >=sys-apps/hotplug-20040923 )"
>  > >
>  > > paludis -qD ipw2200-firmware?
>  >
>  > * net-wireless/ipw2200-firmware
>
> >     Run dependencies:
>  >             >=sys-apps/hotplug-20040923
>
>
> Looks like the version you have installed doesn't have the || dep.

/usr/portage/net-wireless/ipw2200-firmware/ipw2200-firmware-3.0.ebuild:
RDEPEND="|| ( >=sys-fs/udev-096 >=sys-apps/hotplug-20040923 )"

>  > >  > It tries to update java:
>  > >  > * virtual/jre :1.6 [S 1.6.0]
>  > >  >     Reasons: app-office/openoffice-2.4.0:0::installed,
>  > >  > dev-db/hsqldb-1.8.0.9-r1:0::installed, 37 more
>  > >  >
>  > >  > While I have the following in /etc/paludis/package_mask.conf:
>  > >  > >virtual/jvm-1.5.0
>  > >  > >virtual/jdk-1.5.0
>  > >
>  > > Note those're new style virtuals...
>  >
>  > So what should I do in order to keep only 1.5 on my system?
>
>
> You can start by masking the jre and its providers too.

OK, thanks!



More information about the paludis-user mailing list