[paludis-user] Paludis trying to downgrade unmasked package

Nick Rosier nick.rosier at gmail.com
Fri Aug 15 17:21:11 UTC 2008


I'm trying to upgrade a local package of mythtv. This worked until a
couple of days. Using emerge worked but with paludis it failed an now
it's installed paludis is trying to downgrade:

/etc/paludis/package_unmask.conf:

*/*::local
# unmask myth
>=media-tv/mythtv-0.22_beta1
>=x11-themes/mythtv-themes-0.22_beta1
>=media-plugins/mytharchive-0.22_beta1
>=media-plugins/mythbrowser-0.22_beta1
>=media-plugins/mythcontrols-0.22_beta1>=media-plugins/mythflix-0.22_beta1
>=media-plugins/mythgallery-0.22_beta1
>=media-plugins/mythgame-0.22_beta1
>=media-plugins/mythmovies-0.22_beta1
>=media-plugins/mythmusic-0.22_beta1
>=media-plugins/mythnews-0.22_beta1
>=media-plugins/mythphone-0.22_beta1
>=media-plugins/mythvideo-0.22_beta1
>=media-plugins/mythweather-0.22_beta1
>=www-apps/mythweb-0.22_beta1
>=media-plugins/mythzoneminder-0.22_beta1

I've tried several formats media-tv/mythtv, media-tv/mythtv:0.22 but none work.

# paludis -i media-tv/mythtv
Building target list...
Building dependency list...
Dependency error:
  * In program /usr/bin/paludis (--continue-on-failure if-satisfied
--dl-reinstall if-use-changed --show-use-descriptions changed
--show-reasons full --dl-downgrade error --log-level warning
--dl-override-masks tilde-keyword --dl-override-masks repository
--dl-override-masks license) -i media-tv/mythtv:
  * When performing install action from command line:
  * When executing install task:
  * When building dependency list:
  * When adding PackageDepSpec 'media-tv/mythtv':
  * Downgrade to 'media-tv/mythtv-0.21_p18116:0::gentoo' from
'media-tv/mythtv-0.22_beta18155:0::installed' forbidden
(paludis::DowngradeNotAllowedError)


 * No unread news items found

 * Searching for configuration files requiring action...
 * No configuration file updates required



More information about the paludis-user mailing list