[paludis-user] Why does a world update pull qt-3.3.4?

and3k and at stuffit.at
Fri Aug 31 08:42:57 UTC 2007


Hi,

doesn't work:

paludis -ip libkexiv2 kipi-plugins
Building target list...
Building dependency list...

These packages will be installed:

* sys-devel/gcc-config-1.4.0-r2 {:0} [U 1.4.0-r1]  
<sys-devel/gcc-4.2.0::installed>
* media-libs/libkexiv2-0.1.5 {:0} [R] arts -debug xinerama 
<media-plugins/kipi-plugins-0.1.4::gentoo>
* media-libs/freetype-2.1.10-r3 {:2} [D 2.3.5-r1] -bindist -doc zlib 
<x11-libs/qt-3.3.4-r8::gentoo>
* x11-libs/qt-3.3.4-r8 {:3} [D 3.3.8-r3] cups -debug -doc -examples 
(-firebird) gif -immqt -immqt-bc ipv6 mysql nas odbc opengl postgres sqlite 
xinerama <dev-db/qt-unixODBC-3.3.4-r1::gentoo, 
media-libs/libkdcraw-0.1.1::installed>
* dev-db/qt-unixODBC-3.3.4-r1 {:3} [D 3.3.8]  <x11-libs/qt-3.3.4-r8::gentoo>
* media-plugins/kipi-plugins-0.1.4 {:0} [R] arts -debug gphoto2 opengl 
xinerama

Total: 6 packages (1 upgrade, 3 downgrades, 2 rebuilds)

and cat /var/db/pkg/media-plugins/kipi-plugins-0.1.4/RDEPEND
>=media-libs/libkipi-0.1.5 media-libs/libkexiv2 >=media-libs/libkdcraw-0.1.1 
gphoto2? ( >=media-libs/libgphoto2-2.3.1 ) >=media-libs/imlib2-1.1.0 
>=media-gfx/imagemagick-6.2.4 >=media-video/mjpegtools-1.6.0 opengl? ( 
virtual/opengl ) >=media-libs/tiff-3.5 >=dev-libs/libxslt-1.1 
>=kde-base/kdelibs-3.5 =x11-libs/qt-3.3* xinerama? ( x11-libs/libXinerama ) 
arts? ( kde-base/arts )

... i just dont get why the heck is wants to use 3.3.4 .....

kipi-plugins + libkexiv2 are not the only packages that want to pull 3.3.4 
btw, there are a lot more ...

greets

On Friday 31 August 2007 10:04:28 you wrote:
> Hi,
>
> Either re-merge kipi-plugins and libkexiv2, or edit their run
> dependencies under /var/db/pkg/<package name>/RDEPEND.
>
> Zsitvai János





More information about the paludis-user mailing list