[paludis-user] Why does a world update pull qt-3.3.4?

and3k and at stuffit.at
Fri Aug 31 07:03:53 UTC 2007


Hello everybody,

when i run paludis -ip world, it always wants to install qt-3.3.4:
x11-libs/qt-3.3.4-r8 {:3} [D 3.3.8-r3] cups -debug -doc -examples (-firebird) 
gif -immqt -immqt-bc ipv6 mysql nas odbc opengl postgres sqlite xinerama 
<dev-db/qt-unixODBC-3.3.4-r1::gentoo, dev-python/PyQt-3.17.3::installed, 28 
more>  

when i mask it, i always get something like that:
Query error:
  * In program paludis --install --dl-reinstall 
if-use-changed --dl-reinstall-scm weekly --dl-deps-default pre-or-post 
world -p:
  * When performing install action from command line:
  * When executing install task:
  * When adding PackageDepSpec 'media-gfx/gwenview':
  * When adding installed package 'media-gfx/gwenview-1.4.1::installed':
  * When adding build dependencies as post dependencies:
  * When adding PackageDepSpec '>=media-plugins/kipi-plugins-0.1.0_beta2':
  * When adding installed 
package 'media-plugins/kipi-plugins-0.1.4::installed':
  * When adding build dependencies as post dependencies:
  * When adding PackageDepSpec 'media-libs/libkexiv2':
  * When adding installed package 'media-libs/libkexiv2-0.1.5::installed':
  * When adding build dependencies as post dependencies:
  * Inside || ( ) block with other options:
  * When adding PackageDepSpec 'x11-libs/qt[=3.3.8-r2|=3.3.8-r1|=3.3.8|
=3.3.6-r5|=3.3.6-r4|=3.3.6-r3|=3.3.6-r2|=3.3.6-r1|=3.3.6|=3.3.5-r1|=3.3.5|
=3.3.4-r9|=3.3.4-r8|=3.3.4-r7|=3.3.4-r6|=3.3.4-r5|=3.3.4-r4|=3.3.4-r3|
=3.3.4-r2|=3.3.4-r1|=3.3.4|=3.3.3-r3|=3.3.3-r2|=3.3.3-r1|=3.3.3|=3.3.2|
=3.3.1-r2|=3.3.1-r1|=3.3.1|=3.3.0-r1|=3.3.0|=3.2.3-r1|=3.2.3|=3.2.2-r1|
=3.2.2|=3.2.1-r2|=3.2.1-r1|=3.2.1|=3.2.0|=3.1.2-r4|=3.1.2-r3|=3.1.2-r2|
=3.1.2-r1|=3.1.2|=3.1.1-r2|=3.1.1-r1|=3.1.1|=3.1.0-r3|=3.1.0-r2|=3.1.0-r1|
=3.1.0]':
  * All versions of 'x11-libs/qt[=3.3.8-r2|=3.3.8-r1|=3.3.8|=3.3.6-r5|
=3.3.6-r4|=3.3.6-r3|=3.3.6-r2|=3.3.6-r1|=3.3.6|=3.3.5-r1|=3.3.5|=3.3.4-r9|
=3.3.4-r8|=3.3.4-r7|=3.3.4-r6|=3.3.4-r5|=3.3.4-r4|=3.3.4-r3|=3.3.4-r2|
=3.3.4-r1|=3.3.4|=3.3.3-r3|=3.3.3-r2|=3.3.3-r1|=3.3.3|=3.3.2|=3.3.1-r2|
=3.3.1-r1|=3.3.1|=3.3.0-r1|=3.3.0|=3.2.3-r1|=3.2.3|=3.2.2-r1|=3.2.2|
=3.2.1-r2|=3.2.1-r1|=3.2.1|=3.2.0|=3.1.2-r4|=3.1.2-r3|=3.1.2-r2|=3.1.2-r1|
=3.1.2|=3.1.1-r2|=3.1.1-r1|=3.1.1|=3.1.0-r3|=3.1.0-r2|=3.1.0-r1|=3.1.0]' are 
masked. Candidates are:
    * x11-libs/qt-3.3.4-r8::gentoo: Masked by user_mask

but i don't find the reason why it doesn't use qt-3.3.8-r3 as dependency... 

paludis -ip qt:
Building target list...
Building dependency list...

These packages will be installed:

* x11-libs/qt-3.3.8-r3::xeffects {:3} [R] cups -debug -doc -examples 
(-firebird) gif -immqt -immqt-bc ipv6 mysql nas -nis odbc opengl -pertty 
postgres -qt-copy sqlite xinerama <dev-db/qt-unixODBC-3.3.8::installed, 
dev-db/unixODBC-2.2.12::installed, 1 more>
* x11-libs/qt-4.3.1 {:4} [R] accessibility cups dbus -debug -doc -examples 
(-firebird) gif glib jpeg mng mysql nas -nis odbc opengl -pch png postgres 
qt3support sqlite sqlite3 ssl tiff xinerama zlib input_devices: -wacom

hope somebody has an idea why that is...

bye, and3k



More information about the paludis-user mailing list